Dieses Blog durchsuchen

Montag, 20. Mai 2013

[Tutorial] Active Directory Domain Controller on Raspberry Pi



Hallo

In den letzten Tagen hatte ich wiedermal ein wenig Zeit mich meiner kleinen Himbeere zu widmen. Ich habe deshalb ein wenig herumprobiert wie man am effektivsten  einen "Active Directory Domain Controller" aus unserem kleinen Alleskönner machen könnte. Herausgekommen ist das folgende Tutorial welches ihr euch hier herunterladen könnt.

 PDF: Samba 4 Active Directory on Raspberry Pi

Ich habe wie immer versucht das ganze von Beginn an zu erläutern. So fängt es bei der Installation des Raspian Betriebssystemes an und endet mit der Konfiguration der Benutzerordner und Profile in Active Directory.

Ich würde euch bitten mir ein Feedback dazu zu geben.

Ich würde gerne wissen ob alles so wie ich es beschrieben, und auch bei mir getestet, habe auch bei euch funktioniert. Auch das melden von Tippfehlern und falscher Rechtschreibung ist erwünscht.

Eine Webversion des Dokuments wird in den nächsten Tagen hier in meinem Blog erscheinen. Jedoch hatte ich mein Hauptinteresse erst einmal darauf gelegt eine Druckbare Version zu verfassen.

MFG

Kai

Kommentare:

  1. Hi Kai,

    ich finde den Beitrag interessant und finde er sollte einer breiteren Öffentlichkeit zugänglich gemacht werden.
    Darf ich einen CodeProject.com - Artikel basierend auf deinem Artikel schreiben?

    AntwortenLöschen
    Antworten
    1. Heho.

      Klar darfst du gerne machen. Ich würde das dann auch gern Verlinken, da ich davon ausgehe das du das ja eh auf Englisch schreiben würdest, wozu ich derzeit sowieso keine Zeit hätte.
      Erwähne mich nur einfach irgendwo drin ;)

      MFG

      Kai

      Löschen
  2. Hallo Kai,
    vielen Dank für die gelungene Anleitung. Mit deinen Einstellungen hat bei mir auch alles geklappt, jedoch wenn ich eine andere realm (mypi.local) verwenden will komme ich bis zum Punkt. "host -t SRV _ldap._tcp.mypi.local" mit der Fehlermeldung"Host _ldap._tcp.sdt.local not found: 3(NXDOMAIN)". In der smb.conf, Interfaces und beim samba-tool habe ich auch Einstellungen angepasst. Ich bin ratlos.

    AntwortenLöschen
    Antworten
    1. Hallo Roland,

      hast du den Pi mit der geänderten Domäne neu aufgesetzt oder das bestehende System nur geändert?
      So wie es ausschaut gibt es bei dir ein Problem mit der Namensauflösung der Domäne. Aus irgendeinem Grund wird bei deiner Abfrage mittels "host -t SRV _ldap._tcp.mypi.local" aus dem "mypi.local" ein "sdt.local". Hast du eine Solche Domäne noch in deinem Netzwerk? Also einen zweiten primären DC? Übernimmt bei dir der Pi die DNS auflösung oder ein anderer Server, bzw. existieren 2 DNS-Server in deinem Netzwerk? Irgendetwas ändert den Domännamen.
      Was steht denn als nameserver in deiner resolv.conf?
      Du kannst mir gerne auch deine Konfiguration per Mail schicken, dann schau ich da mal drüber.
      Solltest du nur die bestehende Konfiguration geändert haben, versuch mal den Pi komplett neu aufzusetzen. Nach meiner Erfahrung macht ein Nachträgliches ändern der Domäne meistens irgendwelche Probleme.

      MFG

      Kai

      Löschen
    2. Hallo,

      ich hoffe hier wird noch gelesen.

      Ich hänge an der gleichen Stelle. Wenn ich samba starte kommt folgende Fehlermeldung:

      Unknown enumerated value 'True' for 'allow dns updates'

      Wie ist den an dieser Stelle weiter zu verfahren? Stehe da voll auf dem Schlauch und bin für Hilfe dankbar.

      Gruß
      Bernd

      Löschen
    3. Dieser Kommentar wurde vom Autor entfernt.

      Löschen
  3. Hallo Kai,
    sorry für die Vermischung meiner beiden Versuche. Ich habe insgesamt den Server dreimal nacheinander komplett neu aufgesetzt. mit pidomain.local hat es funktioniert. Mit "mypi.local" und danach mit "sdt.local" nicht.
    Auf den Befehl "host -t SRV _ldap._tcp.mypi.local" habe ich natürlich "Host _ldap._tcp.mypi.local not found: 3(NXDOMAIN)" und auf "host -t SRV _ldap._tcp.sdt.local" habe ich "Host _ldap._tcp.sdt.local not found: 3(NXDOMAIN)" erhalten.

    Aber in der Datei " resolv.conf" war der Fehler versteckt.
    Danke.

    AntwortenLöschen
    Antworten
    1. Heho,

      immer gerne. Schön wenn es jetzt funktioniert.

      Mfg

      Kai

      Löschen
    2. Hallo Kai, Hallo Roland.

      erstmal danke für das super HowTo. ich hänge jetzt gerade auch an der gleichen Stelle wie Roland. ein Beispiel wie die resolv.conf aussehen sollte würde mir wahrscheinlich weiterhelfen. Danke im Voraus.

      Löschen
    3. Moin!

      Sieht bei mir genauso aus. Wäre für jede Hilfe dankbar.

      Viele Grüße,
      Darius

      Löschen
  4. hallo ich habe ein Problem bei der Installation (hab dir auch noch mal ne mail geschrieben). Bei der konfig von Samba beim Test sudo /etc/resolv.conf bekomme ich den Fehler das die Datei angeblich nicht da ist. Die datei ist vorhanden da ich sie mit nano editieren könnte was kann ich nun tuen? muss ich samba komplett noch mal installieren? passt was nicht mit dem dns würde ich vermuten. wer weiß rat?!

    AntwortenLöschen
  5. Hallo Kai,

    erstmal vielen Dank für das sehr ausführliche Tutorial. Habe es mir gestern einmal angeschaut nachdem mein Raspberry am Samstag bei mir eingetroffen ist.
    Da ich aktuell ein reines IT-Wiki (wiki.it-knowhow.eu) am aufsetzen bin würde ich gerne deine Anleitung mit übernehmen. Hättest du etwas dagegen einzuwenden?

    Grüße

    Marian

    AntwortenLöschen
    Antworten
    1. Heho,

      freut mich das dir das Tutorial gefällt. Grundsätzlich habe ich nichts dagegen einzuwenden das du es verwendest, solange du einfach irgendwo einen Link zu mir platzierst ;)

      MFG

      Kai

      Löschen
  6. Hallo Kai,

    deine Anleitung ist sehr toll.

    Ich habe aber noch eine Frage, lässt sich über die Microsoft Verwaltungstools so auch die Gruppenrichtlinien verwalten oder müsste dieses gesondert installiert und verwaltet werden.

    Vielen Dank schonmal im vorraus
    Gruß
    Marco

    AntwortenLöschen
    Antworten
    1. Hallo,
      schön das dir das Tutorial gefällt. Ich habe derzeit leider den Pi nicht als DC laufen, da ich ihn für etwas anderes nutze. Grundsätzlich sollte es aber ohne Probleme möglich sein die Gruppenrichtlinien mit den RemoteTools von Windows zu verwalten. Voraussetzung ist das du sie auf dem Windows rechner unter

      Start → Systemsteuerung → Programme → Windows-Funktionen aktivieren und deaktivieren → Remoteserver-Verwaltungstools → Featureverwaltungs-Tools → Tools für die Gruppenrichtlinienverwaltung

      aktiviert hast. Danach solltest du sie ohne Probleme nutzen können.

      Wie gesagt kann ich es derzeit leider nicht testen, werde aber über Weihnachten mal schauen wie die Familie mir Zeit gibt zum ausprobieren ;)

      MFG

      Kai

      Löschen
  7. Hi,

    sehr schönes Tutorial. Was ich jetzt noch toll fände, wenn Du noch eine Anleitung zum Aufsetzen eines DHCP-Servers auf dem DC dran hängst. Oder gibts die vielleicht sogar schon?

    Gruß
    Andy

    AntwortenLöschen
    Antworten
    1. Hallo, ein Tutorial für einen DHCP Server habe ich derzeit leider nicht, da dies bei mir der Router übernimmt und ich den Pi derzeit anderweitig einsetze. Du kannst allerdings gern hier schauen:

      http://elinux.org/Setting_up_your_Raspberry_Pi_as_a_DHCP_Server

      Das dürfte genau das sein was du suchst.

      MFG

      Kai

      Löschen
  8. Muss man zwingen ein RTC-Modul nutzen oder lässt sich der Server auch mit NTP betreiben?

    AntwortenLöschen
    Antworten
    1. Heho,

      das RTC Modul ist nicht zwingend erforderlich. Jedoch würde ich es grundsätzlich verbauen, da es erstens nicht teuer ist (um die 3€) und zweitens dich vor einem Problem bewahrt. Sollte dein Pi nämlich mal keine Verbindung zu einem Zeitserver haben kannst du dich auf keinem PC der Domain mehr anmelden!

      MFG

      Kai

      Löschen
  9. Noch eine Frage die mir gerade einfällt, wie sieht es mit der Geschwindigkeit aus?
    Wenn ich z.B. eine 1 GB über das Netz über Samba auf den RPi schiebe, wie lang dauert das? Wäre es da vllt. besser einen richtigen PC aufzustellen der als Server dient?

    P.S.: Sehr gutes Tutorial!

    AntwortenLöschen
    Antworten
    1. Heho,

      sobald du mit größeren Datenmengen hantierst empfiehlt sich ein richtiger PC/Server auf jeden Fall. Der Pi ist Netzwerkmäßig nicht der Schnellste. Bei mir schaft er übers Lan auf USB Platte nur um die 5MB/s. Du kannst das Tutorial aber auch für Ubuntu auf einem Pc nutzen, oder halt für Ubuntu Server. andere Debian Derivate habe ich noch nicht getestet.

      MFG

      kai

      Löschen
    2. Okay, vielen Danke für die schnelle Antwort.

      Löschen
  10. Hey Kai,

    sehr cooles Tutorial, eine wirklich gute Lösung für kleine Betriebe wie ich anmerken darf.
    Habe das soweit aufgesetzt wie du beschrieben hast, super geklappt.

    Danke dir ;)

    MfG
    Bobby

    AntwortenLöschen
  11. Hallo Kai,

    ich hoffe hier wird noch gelesen.

    Ich hänge an der gleichen Stelle. Wenn ich samba starte kommt folgende Fehlermeldung:

    Unknown enumerated value 'True' for 'allow dns updates'

    Wie ist den an dieser Stelle weiter zu verfahren? Stehe da voll auf dem Schlauch und bin für Hilfe dankbar.

    Gruß
    Bernd

    AntwortenLöschen
    Antworten
    1. Hallo,

      ich lese die Kommentare immer ;) Hab ja keine Wahl, bekomme Sie ja als Mail aufs Handy :D
      Zu deinem Problem:
      Im Grunde dürfte dies kein größeres Problem darstellen und der Server trotzdem Starten. Falls nicht kannst du die Zeile auch auskommentieren. Das ganze hängt mit der Samba Version zusammen. Früher gab es diesen Befehl. Inzwischen heißen die Modi etwas anders:

      # Don't allow any updates | allow unsigned updates | only allow signed updates
      allow dns updates = False | nonsecure | signed

      # If recursive queries = yes is set, the following is also needed
      dns forwarder =

      Näheres zu den einzelnen Modi kannst du hier finden:

      https://wiki.samba.org/index.php/DNS


      MFG

      His

      Löschen
    2. Danke für die fixe Antwort. Dann gehts gleich mal weiter....

      Löschen
    3. Dieser Kommentar wurde vom Autor entfernt.

      Löschen
  12. Dieser Kommentar wurde vom Autor entfernt.

    AntwortenLöschen
    Antworten
    1. Heho,

      ehrlich gesagt finde ich auch gerade keinen Fehler in den Configs.
      Also bissl Fehlersuche :D Irgendwie schaut es nach einem Fehler in der DNS Auflösung aus.

      1. Kann der Pi sich denn selbst Pingen? Also liefert ein "ping ad-server" ein Ergebniss?
      2. Läuft der Samba Prozess? Siehst du ihn mit "top"?
      3. Kannst du die Fritzbox Pingen, oder eine Seite im Netz?

      Ich habe bei mir mehrmals festgestellt das ein erneutes
      sudo /usr/local/samba/bin/samba-tool domain provision
      mir das ganze irgendwie zerschossen hat, vor allem wenn die Werte etwas abgewichen sind. Da half nur ein beginn von 0. Hoffen wir aber mal nicht das es auch bei dir so ist.

      MFG

      His

      Löschen
    2. Ach was mir noch eingefallen ist. Mein Fehler war es oftmals das ich vergessen hatte den Pi, nach Änderungen an den Netzwerksachen, neu zu starten. Hatte ich auch schon 2 Stunden gesucht, nach einem reboot ging es plötzlich.

      Löschen
    3. Hi Kai,
      zu 1: ja /ja
      zu 2.:ja / ja
      zu 3 : ja / ja

      Reboot auch schon gemacht.

      Anfangen bei 0 heißt wirklich bei 0? Quasi mit einer leeren SD-Karte?

      Gruß
      Bernd

      Löschen
    4. Dieser Kommentar wurde vom Autor entfernt.

      Löschen
    5. Sorry,

      hatte heute noch keine Gelegenheit dir zu antworten. Da das ganze ein wenig komplizierter zu sein scheint würde ich empfehlen das wir mal direkt via Mail kommunizieren. Sonnst wird er Kommentarschwanz hier zu lang :D
      Meine Mail-Adresse hast du ja.

      MFG

      Kai

      Löschen
    6. Dieser Kommentar wurde vom Autor entfernt.

      Löschen
  13. Dieser Kommentar wurde vom Autor entfernt.

    AntwortenLöschen
  14. Moin Kai!
    Ich habe alles aufgesetzt, so wie beschrieben. Allerdmings kommt immer diese Ausgabe:
    ;; connection timed out; no servers could be reached
    Das mit dem DNS Update in der smb.conf klappt.
    Hier meine resolv.conf
    nameserver 192.168.178.36
    Ich weiß nicht, was da schief läuft. Vielleicht funkt mir die Fritz Box dazwischen (FritzBox 7390)



    AntwortenLöschen
    Antworten
    1. Hatte was vergessen, due Ausgabe kommt, wenn ich das eingebe: host -t SRV _ldap._tcp.pidomain.local

      Löschen
    2. Heho und Frohe Ostern.

      Das Problem ist zuerstmal wahrscheinlich nicht die FB, die wird erst später zu einem Problem. Wir haben inzwischen festgestellt das Samba in der neueren Rasbian Version Probleme hat sich auf das Interface zu binden. als erstes "Workaround" haben wir folgende Lösung gefunden.

      1. starte Samba mal mit "sudo /usr/local/samba/sbin/samba -i" Dann bekommst du entweder Fehlermeldungen wie "Failed to bind to…", “[xxx failed to Setup Interface]” und “task_server_terminate: [Failed to Startup xxxxxxxxx]” (für XXX steht da natürlich was anderes). Sollte das der Fall sein, so wird Samba nicht funktionieren, da es nicht auf der Netzwerkkarte an den Ports hört.

      2. Schau mal mit “sudo netstat -anp | grep “LISTEN” " ob Samba dort auftaucht, wenn nicht, dann wird dir das folgende bestimmt helfen.

      3. Weise Samba explizit an auf deiner IP zu hören. Dies machst du in der "smb.conf" indem du in den Globalen Teil folgendes hinzufügst:

      “bind Interfaces only = yes”
      “Interfaces = ADRESSEDEINESPI”
      (natürlich ohne Hochkommas und als ADRESSEDEINESPI die Ip des Pi).

      4. danach startest du Samba wieder wie in 1. und schaust mit 2. nach ob es jetzt auftaucht. Die Liste sollte jetzt um einiges länger sein und Samba als Task mit auftauchen.

      5. Um nun mit dem Tutorial weiterarbeiten zu können musst du wissen das Samba jetzt nichtmehr auf "localhost" hört. das heist für alle folgenden Anweisungen musst du "localhost" mit der IP ersetzen, die du in der smb.conf angegeben hast.

      Zum Einbinden eines Clients:

      Es kann passieren das dir die FB und das Win einen Strich durch die Rechnung machen indem sie beide IPv6 nutzen. Dies kannst du überprüfen indem du den DNS im Win auf den Pi änderst und dann mit "nslookup" nachschaust ob dort die Adresse des Pi's steht oder eine IPv6 Adresse. Sollte dies der Fall sein, so wirst du IPv6 im Win abschalten müssen, da die Namensauflösung sonst immer über die FB läuft. Ich arbeite aber gerade an einer Lösung mit IPv6, kann aber noch dauern, da ich arbeitstechnisch viel zu tun habe.

      Ich hoffe das hilft dir erst einmal ein Stückschen weiter.

      MFG

      Kai

      Löschen
  15. Lieber Kai,
    ich habe die Schriite nun so ausgeführt. Der Task mit Samba taucht auch auf. Aber, wenn ich: host -t SRV _ldap._tcp.pidomain.local eingebe, kommt immer noch: ;; connection timed out; no servers could be reached. Ist das nun weiter schlimm?
    Ich bedanke mich aber recht herzlich für die schnelle und Kompetente Hilfe, große Klasse!

    Grüße aus Ostfriesland von der Nordsee!

    Marcel

    AntwortenLöschen
    Antworten
    1. Heho,

      Kannst du mir mal deine etc/network/interfaces per Mail schicken. Bzw. die smb.conf und die resolv.conf und die Ausgabe von 1. und 2. Da schaue ich morgen mal drüber.

      Löschen
  16. Hallo,
    nun hat es geklappt. Den Fehler habe ich ignoriert und weiter gemacht. Beim Clienten habe ich in die Hosts die pidomain.local eingetragen und ich konnte der Domäne aber immer noch nicht joinen, da in der Registry zwei Keys fehlen, die den Domänenbeitritt, egal welcher Domäne verhindern. Ich weiß nun nicht, ob das nur bei mir so ist, aber ich habe diese Keys regsitriert und dann war alles gut. Als der Beitritt geklappt hat, habe ich mich an die Remoteserververwaltung gesetzt und da hat er auch gemeckert, die Domäne wäre nicht vorhanden, Recher neugestartet und dann war Ruhe. Ich will dir die Networkdatei aber lieber nochmal senden, wo finde ich deine E-Mail Adresse?

    AntwortenLöschen
  17. Habe Samba nach der Anleitung auf meinem neuen Raspberry installiert, samba startet nicht, ich bekomme mit samba -i folgenden Fehlerausgabe:

    Failed to bind to ipv6::::389 – NT_STATUS_INVALID_PARAMETER_MIX

    samba -V zeigt mir Version 4.2.0pre1-GIT-93093fa

    Kann es mit der neuesten Version von Samba zu tun haben?

    Hier finde ich was dazu im Internet (ganz unten in den Kommentaren), doch leider auch keine Lösung:

    http://justtinkering.wordpress.com/2013/01/03/activedirectory-domain-controller-with-samba4-on-raspberrypi/

    Gruß Karl

    AntwortenLöschen
    Antworten
    1. Heho,

      das Problem liegt daran das sich Samba nicht auf die Netzwerkadresse binden kann. Behoben bekommst du das eigentlich indem du "bind interfaces only = yes" und "interfaces = ADRESSEDEINESPI" in die smb.conf einträgst. Danach sollte Samba starten und auf der IP deines Raspberry hören. Du kannst das ganze überprüfen indem du nach dem Start von Samba “sudo netstat -anp | grep “LISTEN” " in der Console eingibst. dort müssten dann die Ports mit dem Samba dienst auftauchen.
      Wenn das läuft kannst du allerdings nicht mit den Adressen "localhost" oder "127.0.0.1" weiterarbeiten sondern musst diese durch die IP des Pi ersetzen im Tutorial. Danach sollte es keine Probleme mehr geben.

      MFG

      Kai

      Löschen
  18. Hallo Kai,
    könntest du deine Konfiguration nicht mal als img hochladen, sprich vom Disk Imager read? Ich weiß nun nicht, ob das so schlau wäre, aber das wäre eigendlich eine gute Möglichkeit, oder?? Und dann einfach die IPAdressen u.s.w. anpassen.
    Grüße

    AntwortenLöschen
  19. Hallo Kai,

    klasse HowTo, vielen Dank!!

    Ich habe nur beim Starten der /etc/resolv.conf ein Problem... Ich bekomme immer folgende Meldung:

    /etc/resolv.conf: Zeile 2: nameserver: Kommando nicht gefunden.

    Irgendwie scheint die Namensauflösung nicht zu funktionieren... Hast du da vielleicht eine Idee? Ich komme nicht weiter :/

    Viele Grüße,
    Darius

    AntwortenLöschen
  20. Hallo Kai,

    vielen Dank erstmal für das HowTo. Ich habe die Anleitung auf einer virtuellen Ubuntu Maschine umgesetzt. Bis jetzt hat alles geklappt, nur wenn ein Rechner beitreten will und Ich die Zugangsdaten eingegeben habe, kommt nur diese Fehlermeldung:
    "Fehler beim Versuch, den DNS-Name eines Domänencontrollers in der Domäne, der beigetreten wurde, aufzulösen. Stellen sie sicher, dass dieser Client zum Erreichen eines DNS-Servers konfiguriert ist, der DNS-Name in der Zieldomäne auflösen kann."

    Hast du einen Lösungsansatz dazu? Ich weiß nicht mehr weiter... :(

    Grüße

    AntwortenLöschen
    Antworten
    1. Ich habe das Problem selbst beheben können:
      Mein rechner hat über IPv6 einen anderen DNS Server genommen und deswegen den DC nicht gefunden

      Löschen
  21. Geht das ganze auch auf dem CUBIEBOARD?

    http://www.raspberrypi-kaufen.de/raspberrypi-alternativen.html

    Kann man das Rasberry auch im Laden kaufen wie Saturn ect.pp oder nur Online?

    AntwortenLöschen
    Antworten
    1. Hallo,

      eigentlich sollte das ganze auch auf dem CubieBoard laufen. Wüsste jetzt nicht warum nicht. Du musst das Ganze halt als Leitfaden nehmen und eventuell auf das BS des Boards abwandeln.

      Den Pi kannst du inzwischen auch in Läden wie Konrad, MediMax etc. kaufen. Einfach mal nachfragen. Der Nachteil gegenüber Onlinekauf ist aber das du ihn nichti nnerhalb von 14 Tagen wegen nichtgefallen zurückgeben kannst, sollte er deinen Anforderungen doch nicht entsprechen.

      MFG

      Kai

      Löschen
  22. Hallo Kai,
    ich hatte ja das Problem mot dem Auflösen des Domänenamens. Nun habe ich den Fehler gefunden, es lag an der Fritz Box. Dort ist eine Einstellung versteckt, die Inzerne DNS-Abfragen blockieren heißt, dadrunter ist ein Textbereich, in dem man Domainnamen eingeben kann, bei denen das erlaubt sein soll, in die Liste einfach den Namen eintragen - fertig! Nun hat es geklappt. Ich uabe das Ganze aber nicht mehr mit dem RaspberryPi gemacht, ich habe es mit dem BananPi gemacht. Dieses supertolle Gefährt ist nun bei mir ein vollwertiger AD Server! Sein größter Vorteil - Die netzwerkgeschwindigkeit. Der Router sagt, er hat derzeit eine Annbindung von 2GBit! Und das reicht bei wenigen Usern völlig aus! Ich bedanke mich bei dir fürdiese tolle Anleitung!!
    Liebe Grüße aus Ostfriesland
    Marcel

    AntwortenLöschen
    Antworten
    1. Heho, Freut mich das es funktioniert und das die anleitung dir geholfen hat.
      Ich überlege auch gerade mir einen Banana Pi als Fileserver zuzulegen. Mit dem Pi ist das Netzwerk ja nicht ganz so schnell und der Banana hat noch SATA dran. Kann mir gut vorstellen das das funtioniert.

      Löschen
  23. Hallo Kai,

    Vielen Dank für deine Anleitung. Sie war maßgeblich dafür verantwortlich, dass ich mir einen Pi zugelegt habe :) da ich neuling bin und auch nur selten mit linux arbeite würde ich gerne wissen, ob es möglich ist statt der externen HDD auch ein share auf meinem NAS als speicher zu nutzen und wenn ja, wie müsste ich das machen?

    Viele Grüße,
    Stefan

    AntwortenLöschen
  24. Hallo Kai,

    vielen Dank für deine Behmühungen. Ich habe Raspbian auf dem BananaPi installiert und wollte nun diese Funktion nutzen. Allerdings bin ich nachdem Download nicht mehr weitergekommen. Da kam dann die Meldung configuration failed. Kannst du mir bitte helfen.

    Liebe Grüße

    Lars

    AntwortenLöschen
    Antworten
    1. Heho, gerne helfe ich dir wenn ich Zeit finde. Habe inzwischen auch einen Banana Pi da, sodass ich es auch nachvollziehen könnte. Schreib mir einfach mal ne Mail, da dies wahrscheinlich besser im direkten Kontakt zu klären ist.

      MFG

      Kai

      Löschen
    2. Hi Kai,
      hab nirgendwo ne E-Mail Adresse von dir gefunden :(

      LG

      Lars

      Löschen
  25. Hi,
    ich hänge jetzt schon seit drei Tagen am DNS-Test in deinem Tutorial fest. Egal, was ich in /etc/hosts, /etc/network/interfaces, /etc/resolv.conf oder der smb.conf eintrage, nichts führt zum Erfolg. Jedesmal bekomme ich den Fehler $domain not found 3(NXDOMAIN).
    Hättest du vielleicht Lust, mal über diese Konfigurationen zu schauen? Vielleicht übersehe ich einfach nur einen kleinen Fehler.
    Wenn ja, wie kann ich dich per Mail erreichen?

    Vielen Dank schon im Voraus.

    Ted

    AntwortenLöschen
  26. Hi Ted,
    kann ich machen. Ich habe es vor kurzem auch versucht, komme aber immer noch nicht zum Ziel :(

    Meine E-Mail-Adresse: mayerl797@gmail.com

    LG

    Lars

    AntwortenLöschen
    Antworten
    1. Hi Ted und Lars,

      habe das gleiche Problem seit gerade eben. Habt ihr schon eine Lösung ? Ich kann mich täuschen aber nach einem neustart ging es plötzlich nicht mehr, zuvor hat mit der DNS auflösung alles geklappt.

      Grüße
      Karel

      Löschen
    2. Ich habe den Fehler bei mir so glaube ich gefunden.
      Benutzt ihr eine Fritzbox ? Wenn ja, dann wird eure /etc/resolv.conf immer wieder überschrieben. In dieser darf nur ein Wert stehen, dieser ist die IP Adresse eures PI. Alle anderen Werte habe ich herausgelöscht.

      Probiers mal aus vielleicht hast du ja auch Glück

      Löschen
  27. Dieser Kommentar wurde vom Autor entfernt.

    AntwortenLöschen
  28. Hi,

    riesen Dank für diesen Tutorial. Auch unter Samba 4.4.0 läuft es mit ein paar Anpassungen wunderbar. Diese sind:

    Seite 14
    In smb.conf muss es nun heißen:
    "allow dns updates = signed"

    Seite 16
    Bei der Installation von Kerberos werdet ihr noch 2 mal nach dem Server gefragt, also zum Beispiel "raspberrypi".

    Seite 18:
    Es müsste in der smb.conf "browseable" statt "browsable" heißen, also mit "e".

    Ich hatte bei ein paar Win7 Clients Probleme. Diese konnten das Benutzerprofil nicht laden. Windows bringt eine Meldung: "Sie wurden mit einem temporären Profil angemeldet". Abhilfe brachte "browseable = yes".

    AntwortenLöschen
    Antworten
    1. Danke dir. Werde es versuchen einzuarbeiten wenn ich das original wiederfinde ;) "Plattencrash" Aber ich hab eine Backup irgendwo.

      Löschen
  29. Hi,
    ich komme nicht mal bis zur Seite 14. Ich komme nur bis Seite 12. Bei mir kommt configure failed. Diese Überprüfung wird nicht bestätigt. Deshalb hilft mir dieser Kommentar leider nicht.

    Liebe Grüße

    Lars

    AntwortenLöschen
  30. Hallo,

    danke erstmal für deine tolle Anleitung. Hast du davon evtl eine aktualisierte Version ? Ich hänge gerade bei ./configure für den Samba Server. Die HW Clock ließ sich auch nicht machen denke aber das ich das für das ersttmaöige testen evtl. einfach weglassen kann. Also nochmal zurück... gibt es eine Aktualisierte version deiner Anleitung ?

    AntwortenLöschen
  31. Hallo mal ne Frage ich bekomme das irgendwie nicht hin ..
    hat jemand zufällig ne Backup was ich nur noch rauf spielen kann .. und nur den Domänenammen ändern muss ..

    AntwortenLöschen
  32. libgnutls-dev

    Kann Paket nicht finden

    AntwortenLöschen
  33. Hallo Kai,

    erst einmal vielen Dank für dein super Tutorial!
    Ich habe eine Frage: Hat bei dir die Integration in die Windows Verwaltungstools problemlos funktioniert ? Gibt es da noch etwas zu beachten? In Active Diretory Domänen lässt er sich nicht integrieren. Der Server Manager meint, dass er das Betriebssystem des Zielcomputers nicht verwalten kann. Muss administrator nicht spezielle Rechte oder in anderen Gruppen sein? Beste Grüße, Kai

    AntwortenLöschen